Message from JavaScript discussions

November 2020

— Don't ever try IntersectionObserver for infinite scroll, only scroll event 😑


Hmmh guys, im using leaflet.markercluster which have a peer dep of leaflet~1.3.1 but im using leaflet1.7.1 and this breaks my pipes. it would be unfortunate to downgrade...

— Do you have suggestions?

— First of all, minor versions should not be breaking changes (depends on how strictly they implement semver) so in theory you will be fine keeping the latest 1.x version.

Message permanent page

— In practice, it is possible that there are some minor differences that the other plugin cannot process. You can pin down the dependency with npm shrinkwrap or yarn lock I believe

Message permanent page

— The peer dep is using he tilde -> so everything from 1.3.1 to < 1.4.0 is fine

— Hmm 🤔

— Its tricky, id prefer to npm patch-package the package.json of the leaflet.markercluster, but it didnt worked

Message permanent page

— That does NOT sound like a good idea

— Hahah i know, and i dont think its possible.
Resolving dependencies is one of the worst parts of the job

Message permanent page

— What a good idea to do then ?

— Downgrade or fix the dep and PR