Message from JavaScript discussions

April 2019

— Ticking should probably just be tick


Ok, if this is what you need and works for you it’s fine. But imagine having multiple instances of Game. And I think this is not a OOP pattern like you said you wanted.

— Yeah naming functions and methods is causing me a real headache

— Just make them verbs

— DisplayTime -> getTime

— Could you change this code the way you feel it would be more OOP and paste it here?

— OOP is not a good goal imo

— I was trying to get to this result for six hours, so understand my euphoria 😅

— Display is technically a verb so there so I'm just missing knowledge of common names for variables and functions

Message permanent page

— Why not?

— Display implies it does something with UI or console

— It just returns a value