Message from C, C++ talks
So you would rather add:
this function modifies a vector by rotating the elements positions by 1
void func2(std::vector<int> &x)
rather than actually state what the function does? That is bad coding practice. Naming is key to writing good, readable, code.