Message from JavaScript discussions

February 2018

— I am having a problem with the terminal.
I use Linux Mint 18.3.
When I insert this: npm install -g javascripting

Message permanent page

— 

Npm WARN deprecated sprintf0.1.5: The sprintf package is deprecated in favor of sprintf-js.
npm WARN checkPermissions Missing write access to /usr/lib/node_modules
npm ERR! path /usr/lib/node_modules
npm ERR! code EACCES
npm ERR! errno -13
npm ERR! syscall access
npm ERR! Error: EACCES: permission denied, access '/usr/lib/node_modules'
npm ERR! { Error: EACCES: permission denied, access '/usr/lib/node_modules'
npm ERR! stack: 'Error: EACCES: permission denied, access \'/usr/lib/node_modules\'',
npm ERR! errno: -13,
npm ERR! code: 'EACCES',
npm ERR! syscall: 'access',
npm ERR! path: '/usr/lib/node_modules' }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/fabio/.npm/_logs/2018-02-21T21_09_57_130Z-debug.log

— This is the message that I see.
What can I do about it ?

— Ok, I solved it.

— Sudo? :P

— Yeah all they had to do was read the error haha

— I make the same mistake and have to sit there reading it before facepalming, just because I know that's like the 100'th time I tried to run it without sudo

Message permanent page

— Npx works without sudo though?

— It doesn't touch any root folders I believe

— ¯\_(ツ)_/¯

— Sudo -i

— ?